sobota, 5 marca 2011

Couldn't parse YAML at line - po update RubyGems do wersji 1.6.1

Wygląda na to, że połączenie Ruby 1.9.2 oraz najnowszej wersji RubyGems 1.6.1 domyślnie używa 'psych' jako parsera plików YAML...

Mi nie udało się zainstalować gem'a 'psych', więc trzeba było ustawić inny domyślny parser dla aplikacji.

W pliku boot.rb dodałem następujące linie:
require 'yaml'
YAML::ENGINE.yamler = 'syck'

Brak komentarzy:

Prześlij komentarz